Couscous Party c'est fini !

debug d'une mission

Pour les Masochistes Éditeurs de missions
NesteA
Chouchou
Chouchou
Messages : 23
Enregistré le : ven. 20 janv. 2012, 07:49

debug d'une mission

Messagepar NesteA » ven. 20 janv. 2012, 08:09

Voilà je viens vers vous car j'ai créé une petite mission . celle ci fonctionne parfaitement en test solo, et en hébergement locale....
cependant nous avons fais l’acquisition d'un serveur dédié très récemment , et à ma grande surprise, cette mission met à genoux le serveur , ce qui la rend totalement injouable....
je l'ai désossé de A à Z sans en trouver la cause .... j'en déduis que cela doit se passer bien au delà de mes compétences....

Vu le nombre d'expert que composent votre team , est ce que l'un d'entre vous pourrait y jeter un petit coup d’œil afin de m'orienter dans la bonne direction....

merci d'avance....

j'attends vos réponses pour savoir si cela est possible et pour connaitre la procédure pour vous uploader le PBO....

PEACE :)

Avatar de l’utilisateur
=[TTK]= Memphis007
Grand TranKilou
Grand TranKilou
Âge : 37
Messages : 3260
Enregistré le : mer. 13 janv. 2010, 15:29
Humeur : Binaire
Localisation : 127.0.0.1
Contact :

Re: debug d'une mission

Messagepar =[TTK]= Memphis007 » ven. 20 janv. 2012, 13:32

Pour l'upload de mission, je t'aurais bien dit de la mettre sur megaupload... Toutefois il te reste la solution mediafire.

Concernant le debug en général il te faut les logs du serveur situé sur ton serveur dédié ainsi que le fichier RPT qui se trouve dans ton dossier personnel Windows : C:\Users\NesteA\AppData\Local\ArmA 2 OA\arma2oa.rpt si tu es sous vista ou seven.

En analysant tout le bazar tu devrais être à même de trouver les bugs.

Après pour l'histoire de mettre à genoux le serveur, c'est pas forcément lié à des bugs mais à la conception de tes scripts en eux même. Un script qui se réactualise trop souvent par exemple peut à lui seul paralyser le serveur.
Si ya pas de shell, ya pas de plaisir...

Image

Fingers in the noise. Maxime verdâtre.

Avatar de l’utilisateur
Camille Caz
Grand Gourou
Grand Gourou
Âge : 77
Messages : 1811
Enregistré le : lun. 25 janv. 2010, 22:45
Humeur : paléolithique mais presque
Localisation : près de La Rochelle
Contact :

Re: debug d'une mission

Messagepar Camille Caz » ven. 20 janv. 2012, 13:42

On ne dira jamais assez les désastres engendrés par les scripteurs.
Tant pis pour ceux qui se sentent obligés de penser tout le temps, ils n'avaient qu'à être bretons

Avatar de l’utilisateur
=[TTK]= Magnetone
Retraité
Retraité
Âge : 23
Messages : 166
Enregistré le : mer. 23 nov. 2011, 19:27

Re: debug d'une mission

Messagepar =[TTK]= Magnetone » ven. 20 janv. 2012, 16:53

elle fait planter le serveur avant ou après le lancement de la mission ???
Nous perso, ont a fait planter le serveur à causse des majuscules sur linux :D .

après, (sur ce point j'en suis pas du tout sûr) il faut voir,si, quand tu as créer la mission, tu n'as pas mis des objets qui sont pas présent dans la version vanilla de arma 2
Image

Avatar de l’utilisateur
=[TTK]= Yourry
Grand Scriptou
Grand Scriptou
Âge : 30
Messages : 1601
Enregistré le : mer. 17 mars 2010, 16:39
Localisation : Dans le reblochon !

Re: debug d'une mission

Messagepar =[TTK]= Yourry » ven. 20 janv. 2012, 17:08

Le plus simple; tu déposes ta mission sur médiafire et tu nous donnes le lien de téléchargement.
Pour le reste il faut voir ce qu'il y a dedans.

Vu le nombre d'expert que composent votre team


:lol:
"Les Boches faisaient "Kamarad". Il aurait fallu commencer par ça des deux côtés, pour éviter les massacres organisés par ceux d'en haut, mais le fusil qu'ils nous avaient collé entre les mains, forcément, il a bien fallu qu'il serve et tout le reste à suivit." dixit Tardi et Verney


Image


L'autre jour, en tirant le rouleau de papier cul, toute la cloison est venue avec. dixit Camille Caz

NesteA
Chouchou
Chouchou
Messages : 23
Enregistré le : ven. 20 janv. 2012, 07:49

Re: debug d'une mission

Messagepar NesteA » jeu. 26 janv. 2012, 19:00

merci pour votre réactivité , mais j'ai finalement avorté l'idée de la debugger, pour la refaire sur une autre carte, et la ça marche nickel.... Arma quand tu nous tiens.....

Par contre j'ai quelques petites questions : êtes vous passé à la maj 1.60 ? usez vous du mod Ofrp 3.1 ?


Nous rencontrons de sérieux problèmes de stabilité durant nos parties ; En effet, régulièrement et de manière totalement aléatoire nous subissons des freezs qui au final nous font planté le jeu.... Nous avons d'abord cru que cela était dû à Ofrp et son scripts douteux anti-R3f, mais le problème subsiste même sans ....

On s'interroge donc sur la stabilité de la version 1.60... j'ai pu voir certain rapport de bug qui correspondrait bien à nos symptômes , et j'ai vu qu'une beta avait vu le jour .....

Avez vous rencontré des problèmes similaires ??? toute info sera la bienvenue et encore merci pour votre patience :)

Avatar de l’utilisateur
=[TTK]= Memphis007
Grand TranKilou
Grand TranKilou
Âge : 37
Messages : 3260
Enregistré le : mer. 13 janv. 2010, 15:29
Humeur : Binaire
Localisation : 127.0.0.1
Contact :

Re: debug d'une mission

Messagepar =[TTK]= Memphis007 » jeu. 26 janv. 2012, 19:50

Salut,

Patch 1.60 oui, mod Ofrp oui, mais je ne saurais te dire quelle version, surement une pas trop vieille (on est en train de remettre tout ça à jour)

Pour la stabilité du patch 1.60 aucun soucis de notre coté, ça marche du feu de dieu.
Si ya pas de shell, ya pas de plaisir...

Image

Fingers in the noise. Maxime verdâtre.

Avatar de l’utilisateur
Camille Caz
Grand Gourou
Grand Gourou
Âge : 77
Messages : 1811
Enregistré le : lun. 25 janv. 2010, 22:45
Humeur : paléolithique mais presque
Localisation : près de La Rochelle
Contact :

Re: debug d'une mission

Messagepar Camille Caz » jeu. 26 janv. 2012, 20:01

On fonctionne avec la dernière version, je viens de vérifier, c'est bien la 1.6. C''est le pied total avec notre nouveau serveur, Didier, dont tu as certainement entendu parler. C'est d''une fluidité comme on croyait pas que ça existait, ça bugue jamais et on marche accompagnés par des sons magnifiques dispensés par l'addon @JSRS1.4 accompagné de son inséparble @CBA.
Les bugues, c'est quand tu as un soit serveur pourri soit des missions pourries soit les deux. C'est pas Arma !
Tant pis pour ceux qui se sentent obligés de penser tout le temps, ils n'avaient qu'à être bretons

NesteA
Chouchou
Chouchou
Messages : 23
Enregistré le : ven. 20 janv. 2012, 07:49

Re: debug d'une mission

Messagepar NesteA » jeu. 26 janv. 2012, 21:30

Merci camille, c'est peut être le serveur.... et oui je n'ose imaginé que mes missions soient pourris muahahaha :mrgreen: :mrgreen:

Mais comment le savoir that is the question !!!!

Avatar de l’utilisateur
=[TTK]= Yourry
Grand Scriptou
Grand Scriptou
Âge : 30
Messages : 1601
Enregistré le : mer. 17 mars 2010, 16:39
Localisation : Dans le reblochon !

Re: debug d'une mission

Messagepar =[TTK]= Yourry » jeu. 26 janv. 2012, 22:41

Oui en effet certain ont des soucis avec la version 1.60.
Pour même moi, les déconnexions sont plus régulières (j'ai trouvé cependant une petite parade pour éviter de redémarrer le jeu).

Je te conseil d'installer la version Bêta qui corrige encore quelques bugs (la version bêta est en .exe, soit tu lances cette version soit la 1.60 seule. Tu as le choix).
Aussi, je ne connais pas le lien mais j'ai lu que Dwarden (un dévellopeur de Arma) sur le fofo de bis accepte qu'on lui envois un mail avec les logs pour jeter un œil.

Pour le reste après ce sont des conseils classiques du style de mettre à jour les pilotes des cartes graphiques et autres.

Bon courage.
"Les Boches faisaient "Kamarad". Il aurait fallu commencer par ça des deux côtés, pour éviter les massacres organisés par ceux d'en haut, mais le fusil qu'ils nous avaient collé entre les mains, forcément, il a bien fallu qu'il serve et tout le reste à suivit." dixit Tardi et Verney


Image


L'autre jour, en tirant le rouleau de papier cul, toute la cloison est venue avec. dixit Camille Caz

NesteA
Chouchou
Chouchou
Messages : 23
Enregistré le : ven. 20 janv. 2012, 07:49

Re: debug d'une mission

Messagepar NesteA » ven. 27 janv. 2012, 16:13

merci yourry , je pense qu'on va testé la bêta.... Ce n'est pas un problème de config ou de drivers étant donné que l'on rencontre tous le même souci .... merci pour les infos en tous cas :)


  • Sujets similaires
    Réponses
    Vues
    Dernier message

Retourner vers « Edition ArmA II / OA »

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité

Thème adapté de Prosilver par Memphis007 - Team TranKilou ©
Développé par phpBB® Forum Software © phpBB Limited
Traduit par phpBB-fr.com